Back to overview
Degraded

We are investigating an issue with our backend services

Nov 24 at 09:52am GMT
Affected services
Kowalah Application

Resolved
Nov 24 at 11:15am GMT

Our upstream provider has implemented a fix. We will continue monitoring.

Updated
Nov 24 at 10:04am GMT

Our upstream providers has identified issues with failing requests across a range of services Their Engineering team is working to resolve this now.

Created
Nov 24 at 09:52am GMT

Some users have reported an issue using Kowalah. We are investigating with our upstream providers.